Bug Tracker

Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13183 closed bug (fixed)

Wrong animation initial value calculation (1.9.0rc1)

Reported by: anonymous Owned by: mikesherov
Priority: high Milestone: 1.9.1
Component: effects Version: 1.9b1
Keywords: Cc: mikesherov
Blocked by: Blocking:

Description

1.9.0rc1 sets wrong initial values for width and height when animations starts.

Simple demo - http://jsfiddle.net/xAbRz/ - the block should only move left, but it appears bigger at the start and then starts resizing, too.

Looks like jQuery animation method uses outerWidth()/outerHeight() instead of width()/height(), because this issue dissapears if padding is removed.

Works fine using prvious versions.

Change History (15)

comment:1 Changed 4 years ago by dmethvin

  • Cc mikesherov added
  • Status changed from new to open

I agree with your basic analysis; @mikesherov does this make sense to you?

comment:2 Changed 4 years ago by mikesherov

  • Component changed from unfiled to effects
  • Owner set to mikesherov
  • Priority changed from undecided to high
  • Status changed from open to assigned

This is a regression in 1.9.0 from 1.8.3. I'll investigate.

comment:3 Changed 4 years ago by Mike Sherov

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix #13183: Wrong animation initial value calc. Close gh-1136.

Changeset: 65df32dc21dc315fe0dcccdcf7d07884f4794ccd

comment:4 Changed 4 years ago by Mike Sherov

Fix #13183: Wrong animation initial value calc. Ref gh-1136.

Changeset: 10cc33e27beb56e41bea1274bc3b51b1c59af9af

comment:5 Changed 4 years ago by mikesherov

#13238 is a duplicate of this ticket.

comment:6 Changed 4 years ago by scottgonzalez

This is marked fixed, but doesn't have a milestone.

comment:7 Changed 4 years ago by dmethvin

  • Milestone changed from None to 1.9.1

Well NOW it does!

comment:8 Changed 4 years ago by mikesherov

#13254 is a duplicate of this ticket.

comment:9 Changed 4 years ago by dmethvin

#13264 is a duplicate of this ticket.

comment:10 Changed 4 years ago by dmethvin

#13272 is a duplicate of this ticket.

comment:11 Changed 4 years ago by mikesherov

#13284 is a duplicate of this ticket.

comment:12 Changed 4 years ago by mikesherov

#13317 is a duplicate of this ticket.

comment:13 Changed 4 years ago by mikesherov

#13325 is a duplicate of this ticket.

comment:14 Changed 4 years ago by mikesherov

#13340 is a duplicate of this ticket.

comment:15 Changed 4 years ago by dmethvin

#13361 is a duplicate of this ticket.

Please follow the bug reporting guidlines and use jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

Modify Ticket

Change Properties
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.