Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13272 closed bug (duplicate)

1.9 Regression - padding is added to width/height when .stop()ing and showing an element

Reported by: Ult Combo Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Test case:

http://jsfiddle.net/jCKYM/1/

Code:

$div.stop().toggle(600);

Stopping a toggle animation while it is in progress and consecutively calling another toggle will add the paddingLeft and paddingRight to the element's width, as well as paddingTop and paddingBottom to the height.

It also affects the regular .show/.hide animation methods.

In .show(), the element animates further than its actual dimensions before suddenly having its proportions fixed at the last step of the animation.

.hide() behaves similarly, but rather the element is extended beyond its actual dimensions (by the value of the padding) at the beginning of the animation (obviously).

Regression from 1.8.3

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13183.
Looks like we have fixed this in the -git build so it will be in 1.9.1 in a week or two.

comment:2 Changed 6 years ago by Ult Combo

Oh thanks for the quick reply @dmethvin, I thought this would have been posted already but couldn't find a duplicate. =]

Last edited 6 years ago by Ult Combo (previous) (diff)
Note: See TracTickets for help on using tickets.