Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13264 closed bug (duplicate)

jQuery 1.9 stop().slideToggle jittery bug

Reported by: shaun@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Just noticed this problem with jQuery 1.9 and .slideToggle (and possibly all toggle animations). I have a single block-style anchor that slides up from the bottom of a div using .slideToggle. Upon hover, the box rises, and upon mouse exit, it slides back down.

The bug I've noticed is that the slide animation, in general, is a lot choppier than it used to be. It appears the slide over-extends, depending on how sporadic the mouse movement is. If I hover in-out rapidly, I can get the .slide effect to essentially grow to the entire height of the containing div. Even if I set the anchor with a height of 20px, the toggle effect will allow it to grow to 40px, 50px, etc+.

Here is a jsfiddle replica of what I'm experiencing. Problem occurs on all Chrome, FireFox and Safari.

http://jsfiddle.net/Gamw7/

Reverting back to 1.8 appears to solve the problem. Was there a change in syntax that I messed up on? Or is this a genuine bug?

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13183.
Looks like this is fixed in the -git build.

Note: See TracTickets for help on using tickets.