Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#8123 closed bug (fixed)

.clone() defaults to cloning events in 1.5

Reported by: scottgonzalez Owned by: john
Priority: blocker Milestone: 1.5.1
Component: event Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

The default behavior of .clone() is not supposed to copy events, but as of 1.5 it does.

Change History (12)

comment:1 Changed 5 years ago by john

  • Component changed from unfiled to event
  • Milestone changed from 1.next to 1.5.1
  • Owner set to john
  • Priority changed from undecided to blocker
  • Status changed from new to assigned

comment:3 Changed 5 years ago by jeresig

  • Resolution set to fixed
  • Status changed from assigned to closed

The default for .clone() is to not clone any events. Fixes #8123.

Changeset: 375b78783825b9adab7a01541faf99f98ef7ecbd

comment:4 Changed 5 years ago by jitter

#8131 is a duplicate of this ticket.

comment:5 Changed 5 years ago by rwaldron

#8161 is a duplicate of this ticket.

comment:6 Changed 5 years ago by rwaldron

#8170 is a duplicate of this ticket.

comment:7 Changed 5 years ago by jitter

#8182 is a duplicate of this ticket.

comment:8 Changed 5 years ago by jitter

#8140 is a duplicate of this ticket.

comment:9 Changed 5 years ago by etiger13

with the patch, the default behavior for deepWithDataAndEvents is changing from false to whatever WithDataAndEvents is. Is that correct and intended?

comment:10 Changed 5 years ago by rwaldron

Yes, correct and intended

comment:11 Changed 5 years ago by jitter

#8299 is a duplicate of this ticket.

comment:12 Changed 5 years ago by addyosmani

#10212 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.