Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8720 closed bug (duplicate)

:has fails with some combinations of other selectors

Reported by: danheberden Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: :has Cc:
Blocked by: Blocking:

Description (last modified by danheberden)

Since there were a few other tickets expressing different parts of the busted functionality, I opted to place all of them together in one bug and leave a good test case that can easily be updated to test/express further issues.

So if you are having troubles with :has in your selector, comment here and fork the test-case with new tests showing how it fails.

http://jsfiddle.net/danheberden/F7gzn/

Currently:

:has( li:eq( 2 ) )
:has( li:lt( 1 ) )
:has( li:gt( 1 ) )
:has( .test:not( .done ) ) // but :has( :not( .done ).test ) works
:has( li:not( :contains( nup ) )

Replaces: #4322, #2683, #6723, #4773

Change History (9)

comment:1 Changed 9 years ago by danheberden

Component: unfiledselector
Keywords: :has added
Priority: undecidedlow
Status: newopen

comment:2 Changed 9 years ago by danheberden

#2683 is a duplicate of this ticket.

comment:3 Changed 9 years ago by danheberden

#4322 is a duplicate of this ticket.

comment:4 Changed 9 years ago by danheberden

#6723 is a duplicate of this ticket.

comment:5 Changed 9 years ago by danheberden

Description: modified (diff)

comment:6 Changed 9 years ago by danheberden

#4773 is a duplicate of this ticket.

comment:7 Changed 9 years ago by AlistairB

Added ul:has(.whatever:contains(bar))

http://jsfiddle.net/AlistairB/F7gzn/5/

This bug should be at least med priority IMHO.

comment:8 Changed 8 years ago by john

Resolution: duplicate
Status: openclosed

comment:9 Changed 8 years ago by john

Duplicate of #8132.

Note: See TracTickets for help on using tickets.