Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4773 closed bug (duplicate)

":has" sometimes can not find the right elements

Reported by: caii Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: has Cc:
Blocked by: Blocking:

Description

<script src="http://jqueryjs.googlecode.com/files/jquery-1.3.2.min.js"></script> <ul><li>0</li><li>0</li></ul>

<ul><li>1</li><li>1</li><li>1</li><li>1</li></ul>

<script> $("ul:has(li:eq(2))").css("background","red")/*can't find the second "ul" with jquery 1.3.2 but in jquery 1.2.6 ,this work correct.*/ </script>

Change History (3)

comment:1 Changed 9 years ago by dmethvin

Status: newopen

http://jsfiddle.net/dmethvin/GXLUY/

Confirmed. Should :has() be documented to only contain simple element/id selectors and not pseudos like :eq?

comment:2 Changed 8 years ago by danheberden

Resolution: duplicate
Status: openclosed

comment:3 Changed 8 years ago by danheberden

Duplicate of #8720.

Note: See TracTickets for help on using tickets.