Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8132 closed bug (duplicate)

:has with :nth-child throws syntax error

Reported by: jrduncans Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

A selector combining :has with :nth-child throws a syntax error. Trying it out on jsFiddle indicates it worked in 1.2.6, but not since. http://jsfiddle.net/Yavmn/1/

Change History (7)

comment:1 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedhigh
Status: newopen

comment:2 Changed 9 years ago by jitter

#8237 is a duplicate of this ticket.

comment:3 Changed 9 years ago by snover

#8303 is a duplicate of this ticket.

comment:4 Changed 8 years ago by john

#8720 is a duplicate of this ticket.

comment:5 Changed 8 years ago by john

Resolution: duplicate
Status: openclosed

comment:6 Changed 8 years ago by john

Duplicate of #7010.

comment:7 Changed 8 years ago by AlistairB

As per 8720, which was closed as a duplicate, this bug is not just involving :nth-child. See last 2 failing tests:

ul:has(li:not(:contains(nup)): 0 (expected: 1)

ul:has(.whatever:contains(bar)): 0 (expected: 1)

http://jsfiddle.net/AlistairB/F7gzn/5/

Using :has with :contains is also not working.

Looking at the other duplicates there appear to be other failing cases as well.

Note: See TracTickets for help on using tickets.