Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8237 closed bug (duplicate)

:HAS with :NTH-CHILD not working under IE

Reported by: hogusa91@… Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Following example works great with FF,Opera,Safari but not IE8 (IE6/IE7 untested) http://jsfiddle.net/Vc9ud/

New version of jQuery throw a syntax error.

Change History (4)

comment:1 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed
Version: 1.4.41.5

comment:2 Changed 9 years ago by jitter

Duplicate of #8132.

comment:3 Changed 9 years ago by hogusa91@…

Why duplicate? Its a different bug which only happens under IE. I found this bug with 1.4.4. See jsfiddle link in description. Was this "fixed" in 1.5?

comment:4 in reply to:  3 Changed 9 years ago by jitter

Replying to hogusa91@…:

Why duplicate? Its a different bug which only happens under IE. I found this bug with 1.4.4. See jsfiddle link in description. Was this "fixed" in 1.5?

Duplicate because these bugs have the same root cause, a regex matching bug in Sizzle. You just found a variation of this which happened to work in some browsers.

Note: See TracTickets for help on using tickets.