Bug Tracker

Opened 12 years ago

Closed 9 years ago

Last modified 8 years ago

#2683 closed bug (duplicate)

:has and :not pseudo-selectors don't play well together

Reported by: nkallen Owned by:
Priority: low Milestone:
Component: selector Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

$('tr:has(td.name:contains(bob))') this works

$('tr:has(td.name:not(:contains(bob)))') this doesn't

$('td.name:not(:contains(bob))') this does

See http://pastie.caboo.se/177061 for full details

Change History (6)

comment:1 Changed 12 years ago by upandhigh

as I know atm jQuery supports only one level nesting. so it's because your second variant doesn't work.

tr:has(td.name:not(someval)) - it's one level nesting and this one is OK tr:has(td.name:not(:contains(someval))) - this one is second level nesting and atm jQuery doesn't support it.

comment:2 Changed 9 years ago by dmethvin

Component: coreselector
Milestone: 1.2.4
Priority: majorlow
Status: newopen
Version: 1.2.31.4.3

http://jsfiddle.net/dmethvin/6vg6E/

:has(:contains()) works fine but :has(:not(:contains())) dies.

comment:3 Changed 9 years ago by danheberden

Milestone: 1.7

comment:4 Changed 9 years ago by danheberden

Resolution: duplicate
Status: openclosed

comment:5 Changed 9 years ago by danheberden

Duplicate of #8720.

comment:6 Changed 8 years ago by dmethvin

Milestone: 1.7
Note: See TracTickets for help on using tickets.