Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4322 closed bug (duplicate)

nested :not inside :has doesn't work in FF3 and Safari 4

Reported by: besh Owned by:
Priority: low Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Works (tested) in IE6/7, Opera 9.6, Google Chrome.
Doesn't work in FF3 and Safari 4 (no error, just the selector doesn't match any elements).

Markup:

<div>
	<p class="test">Test</p>
</div>
<div>
	<p class="test done">Test done</p>
</div>

Selector, looking for <div>s with p.test but not p.test.done:

$("div:has(.test:not(.done))");

Basic testcase:
http://jsbin.com/ofeme

Change History (4)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledselector

Oddly, switching the order of the two filters does work properly:

div:has(:not(.fixed).help)

comment:2 Changed 8 years ago by dmethvin

Priority: majorlow
Status: newopen

comment:3 Changed 8 years ago by danheberden

Resolution: duplicate
Status: openclosed

comment:4 Changed 8 years ago by danheberden

Duplicate of #8720.

Note: See TracTickets for help on using tickets.