Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13573 closed bug (duplicate)

checked property should be treated specially

Reported by: lionel8000 Owned by:
Priority: undecided Milestone: None
Component: attributes Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

when I used elements.attr("checked",true) it works first time but when I used elements.attr("checked",true) after a call to elements.removeAttr('checked'); it will not work.

the reason is on line 2405 () of jquery-1.9.1.js before the code elem.removeAttribute( getSetAttribute ? name : propName ) is called the elem[propName] = false is called first,whick should be not called for the checked property.. SO the checked property should be treated specially

Change History (11)

comment:1 Changed 6 years ago by gibson042

Component: unfiledattributes
Resolution: duplicate
Status: newclosed

Duplicate of #13245.

comment:2 Changed 6 years ago by dmethvin

The jQuery 1.9 Upgrade Guide discusses this and the jQuery Migrate plugin warns about it. Every blog post since the 1.9 release in January pleads with people to read the upgrade guide and use the plugin. The download page emphasizes it as well.

comment:3 Changed 6 years ago by dmethvin

#13955 is a duplicate of this ticket.

comment:4 Changed 6 years ago by dmethvin

#14009 is a duplicate of this ticket.

comment:5 Changed 6 years ago by dmethvin

#14182 is a duplicate of this ticket.

comment:6 Changed 6 years ago by timmywil

#14263 is a duplicate of this ticket.

comment:7 Changed 6 years ago by timmywil

#14278 is a duplicate of this ticket.

comment:8 Changed 6 years ago by timmywil

#14297 is a duplicate of this ticket.

comment:9 Changed 6 years ago by timmywil

#14300 is a duplicate of this ticket.

comment:10 Changed 6 years ago by dmethvin

#14416 is a duplicate of this ticket.

comment:11 Changed 6 years ago by timmywil

#14461 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.