Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7608 closed bug (fixed)

Opera 10.63 - animate width fails when inline style initialized to "width: 0%"

Reported by: mechismo Owned by: Rick Waldron
Priority: blocker Milestone: 1.5
Component: css Version: 1.4.4
Keywords: regression Cc:
Blocked by: Blocking:

Description

Line 5407 appears to be the culprit. Worked in 1.4.3 but a re-factor in 1.4.4 (lines 5475 - 5526) results in elem.runtimeStyle being queried however this property not supported by Opera:

Uncaught exception: TypeError: Cannot convert 'a.runtimeStyle' to object

<div style="width: 200px;border:solid 1px red;">
    <div  id="test" style="width:0%; background:#000;">&nbsp;</div>
</div>
<script type="text/javascript">
    $(function () {
        var val = 50;
	$("#test").animate( { width: val }, 1000);
    });
</script>

Working example here: http://jsfiddle.net/Kc87a/1/

Change History (14)

comment:1 Changed 9 years ago by snover

Component: unfiledcss
Keywords: regression added
Milestone: 1.51.4.5
Priority: undecidedblocker
Status: newopen

comment:2 Changed 9 years ago by jitter

#7759 is a duplicate of this ticket.

comment:3 Changed 9 years ago by chris.tandiono@…

I doubt this is useful information, but it also does not work in Opera 11.

comment:4 Changed 9 years ago by jitter

#7838 is a duplicate of this ticket.

comment:5 Changed 9 years ago by evuigner@…

Will not help, but steel there with jQuery-git

comment:6 Changed 9 years ago by Rick Waldron

Owner: set to Rick Waldron
Status: openassigned

comment:7 Changed 9 years ago by Rick Waldron

Milestone: 1.4.51.5

comment:8 Changed 9 years ago by Colin Snover

Resolution: fixed
Status: assignedclosed

Revert fb4445070cd9e06929c7b6f27c10dbf42d4a3367 which is no longer necessary with the release of Opera 11. Fixes #7608.

Changeset: 012f0c3b4bd3d04c2f3e1ea80fc1230901d607d9

comment:9 Changed 9 years ago by Rick Waldron

Resolution: fixed
Status: closedreopened

comment:10 Changed 9 years ago by Rick Waldron

Status: reopenedassigned

comment:11 Changed 9 years ago by jeresig

Resolution: fixed
Status: assignedclosed

Revert "Revert fb4445070cd9e06929c7b6f27c10dbf42d4a3367 which is no longer necessary with the release of Opera 11. Fixes #7608." We will be continuing to support Opera 10.6 in jQuery 1.5.

This reverts commit 012f0c3b4bd3d04c2f3e1ea80fc1230901d607d9.

Changeset: cf7ddcf79a3d4d455711b67b252b19ae343645b1

comment:12 Changed 9 years ago by jitter

Resolution: fixed
Status: closedreopened

comment:13 Changed 9 years ago by jitter

Status: reopenedopen

comment:14 Changed 9 years ago by john

Resolution: fixed
Status: openclosed

Landed rwaldron's pull.

Note: See TracTickets for help on using tickets.