Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7759 closed bug (duplicate)

opera browser: Uncaught exception: TypeError: Cannot convert 'elem.runtimeStyle' to object

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Others browsers working good. About bug when it appears, below is error log for opera:

Uncaught exception: TypeError: Cannot convert 'elem.runtimeStyle' to object

Error thrown at line 5517, column 3 in <anonymous function: currentStyle>(elem, name) in http://192.168.20.100/assets/19e4a1ff/jquery.js:

elem.runtimeStyle.left = elem.currentStyle.left;

called from line 5408, column 6 in <anonymous function: get>(elem, computed, extra) in http://192.168.20.100/assets/19e4a1ff/jquery.js:

val = currentStyle( elem, name, name );

called from line 5354, column 2 in <anonymous function: css>(elem, name, extra) in http://192.168.20.100/assets/19e4a1ff/jquery.js:

if ( hooks && "get" in hooks && (ret = hooks.get( elem, true, extra )) !== undefined )

Change History (3)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the latest jQuery release and the jQuery 0 GIT version to ensure the issue still exists. Be Excellent to eachother!

comment:2 Changed 8 years ago by jitter

Resolution: duplicate
Status: pendingclosed

comment:3 Changed 8 years ago by jitter

Duplicate of #7608.

Note: See TracTickets for help on using tickets.