Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#9879 closed bug (invalid)

removeAttr('readonly')

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

I invoke $(selector).removeAttr('readonly'),but the element is still readonly in IE8.

Change History (6)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledattributes
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/

Open the link and click to "Fork" (in the top menu) to get started.

comment:2 in reply to:  description Changed 8 years ago by anonymous

Status: pendingnew

Replying to anonymous:

I invoke $(selector).removeAttr('readonly'),but the element is still readonly in IE8.

Same in IE9

comment:3 Changed 8 years ago by dmethvin

Resolution: invalid
Status: newclosed

Please use .prop("readonly", false) to change the in-memory DOM state of the element. Attributes are, in general, only reliable when used to set the initial state as HTML markup is loaded.

comment:4 Changed 8 years ago by dmethvin

#9978 is a duplicate of this ticket.

comment:5 Changed 8 years ago by dmethvin

#10018 is a duplicate of this ticket.

comment:6 Changed 7 years ago by dmethvin

#12012 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.