Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9285 closed bug (fixed)

custom trigger

Reported by: anonymous Owned by: rwaldron
Priority: low Milestone: 1.6.2
Component: event Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

$("#orderproduct").live('fill', function (e, i){

alert(i);

});

$("#orderproduct").trigger('fill', 0);

result: undefined (not 0)!!!

Change History (10)

comment:1 Changed 5 years ago by addyosmani

  • Component changed from unfiled to event
  • Owner set to anonymous
  • Priority changed from undecided to low
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 5 years ago by rwaldron

  • Owner changed from anonymous to rwaldron
  • Status changed from pending to assigned

comment:4 Changed 5 years ago by timmywil

  • Milestone changed from 1.next to 1.6.2

comment:5 Changed 5 years ago by Rick Waldron

  • Resolution set to fixed
  • Status changed from assigned to closed

Landing pull request 377. Check custom data != null(undefined), allows zero; Fixes #9285.

More Details:

comment:6 Changed 5 years ago by dmethvin

  • Keywords needsdocs added

The docs page for .trigger() says the data arg to trigger should be "An array of additional parameters to pass along to the event handler", but our consensus is that other things (particularly Objects) should be valid as well.

comment:7 Changed 5 years ago by rwaldron

+1

comment:8 Changed 5 years ago by dmethvin

  • Keywords needsdocs removed

comment:9 Changed 5 years ago by timmywil

#9421 is a duplicate of this ticket.

comment:10 Changed 5 years ago by rwaldron

#9511 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.