Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8988 closed bug (invalid)

function is not supported

Reported by: wtsoftware@… Owned by: wtsoftware@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

elem.setAttribute is not a function jquery-1.6rc1.js Line 2198

Change History (4)

comment:1 Changed 9 years ago by timmywil

Component: unfiledattributes
Owner: set to wtsoftware@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by Stephen Clouse <stephenclouse@…>

Confirming that this bug still exists in 1.6 release (line is now 2206).

Actually the failure mode I've seen personally is exactly the same as #7497 (which was closed as dup of #7500), upgrade to 1.6 and jquery.event.drag-2.0 suddenly stops working because it tries to call .attr on the document object. So this looks an awful lot like a regression of #7500, or really a re-regression (it was broken in 1.4.4, fixed in 1.5, re-broken in 1.6).

comment:3 Changed 9 years ago by Stephen Clouse <stephenclouse@…>

http://jsfiddle.net/S2z8k/3/

Works on 1.5, error on 1.6 and edge

comment:4 Changed 9 years ago by timmywil

Resolution: invalid
Status: pendingclosed
Version: 1.6rc11.6

As the docs for jQuery 1.6 state, do not use attr on the window or document as they cannot contain attributes. See http://api.jquery.com/prop and http://api.jquery.com/attr.

Note: See TracTickets for help on using tickets.