Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8875 closed bug (invalid)

Permission denied to access property 'nodeType'

Reported by: Rudi Feijo <rudibr@…> Owned by: Rudi Feijo <rudibr@…>
Priority: undecided Milestone: 1.next
Component: core Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

Problem with jquery 1.4.2 with FF4

The offending line 84 on jquery-1.4.2.js :

if ( selector.nodeType ) {

My code wich resulted in the error :

if(window.opener) {

var target_window = window.opener;

} else {

var target_window = window;

}

changing the href here caused the crash :

$(target_window.location).attr('href', data.projectURL);

workaround was manual js : target_window.location.href =

data.projectURL;

Change History (8)

comment:1 Changed 9 years ago by ajpiano

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by ajpiano

Duplicate of #7709.

comment:3 Changed 9 years ago by ajpiano

Resolution: duplicate
Status: closedreopened

comment:4 Changed 9 years ago by ajpiano

Owner: set to Rudi Feijo <rudibr@…>
Status: reopenedpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report but there simply isn't enough information included in this report to understand what is going on.

We require that all bug reports include a valid reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. This enables us to more easily investigate this issue further.

So please report back with more information and a reproducible test case and we will be more than happy to further investigate this issue.

comment:5 Changed 9 years ago by Rick Waldron

Component: unfiledcore

This may very well be a duplicate of #7500

comment:6 Changed 9 years ago by dmethvin

Resolution: invalid
Status: pendingclosed

Your workaround isn't a workaround, it's the way you *should* be setting a property on a Javascript object. There is no reason to use jQuery to do this, it just takes a lot longer and doesn't always work -- because it's not designed to work.

comment:7 Changed 9 years ago by Rudi Feijo <rudibr@…>

Handle everything which isn't a DOM element node

comment:8 Changed 9 years ago by Rick Waldron

I'm not sure what you're referring to "Handle everything which isn't a DOM element node", although it sounds like something that might've been a comment in the source at one time.

Regardless, this ticket reports on out-of-date version of jQuery against a case that jQuery doesn't claim to support.

Note: See TracTickets for help on using tickets.