Bug Tracker

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#7709 closed bug (fixed)

Permission denied to access property 'nodeType' from a non-chrome Firefox/3.5.15

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.6
Component: attributes Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

MESSAGE:Permission denied to access property 'nodeType' from a non-chrome context LINE:24 FILE:http://.../js/jquery.js DATE: 2010-12-06 09:04

Can you add "if (nodeType)" or "if (typeof nodeType == blabla)" to the statment?

Change History (8)

comment:1 Changed 6 years ago by jitter

  • Owner set to anonymous
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project by writing a bug report but there simply isn't enough information included in this report to understand what is going on.

  • Are you using a minified version of jQuery? If yes please use the development version in order to get a meaningful line number.
  • What is triggering this error? What is your code doing?
  • Is it reproducible?
  • Did you try a newer FF and with the latest jQuery version?

(just googling for error messages similar to yours yields many reports on other bug trackers. From what I can tell this is a FF bug which should be resolved in the 3.6.x branch)

We require that all bug reports include a valid reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. This enables us to more easily investigate this issue further.

So please report back with more information and a reproducible test case and we will be more than happy to further investigate this issue.


How to report bugs

comment:2 Changed 6 years ago by trac-o-bot

  • Resolution set to invalid
  • Status changed from pending to closed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 5 years ago by rudibr@…

Pitching in...I had the same problem with jquery 1.4.2 with FF4

The offending line 84 on jquery-1.4.2.js :

if ( selector.nodeType ) {

My code wich resulted in the error :

if(window.opener) {

var target_window = window.opener;

} else {

var target_window = window;

}

changing the href here caused the crash : $(target_window.location).attr('href', data.projectURL);

workaround was manual js : target_window.location.href = data.projectURL;

comment:4 Changed 5 years ago by ajpiano

#8875 is a duplicate of this ticket.

comment:5 Changed 5 years ago by ajpiano

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by rwaldron

  • Component changed from unfiled to core

This may very well be a duplicate of #7500

comment:7 Changed 5 years ago by timmywil

Is this ticket not invalid? What's the use case?

comment:8 Changed 5 years ago by timmywil

  • Component changed from core to attributes
  • Priority changed from undecided to low
  • Resolution set to fixed
  • Status changed from reopened to closed

attr does not support plain objects. The upcoming prop will be able to handle this.

Note: See TracTickets for help on using tickets.