Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8468 closed bug (wontfix)

Find by multiple selector return different value in Opera

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.7
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by ajpiano)

Requirements in html:

  1. element input with class 'vdata' doesn't exists in html
  2. element select with class 'vdata' exists in html

Query: jQuery(this).find("input.vdata,select.vdata :selected").val();

query return 'undefined' in Opera in IE 8, Chrome 9.0.597.107 and Firefox 3.6.13 return selected value in element 'select'

Change History (26)

comment:1 Changed 9 years ago by dmethvin

Owner: set to anonymous
Status: newpending

Hi, can you please post a test case built using jsfiddle.net? The code snippet you provided isn't enough since it's not even clear what "this" is.

comment:2 Changed 9 years ago by anonymous

Status: pendingnew

I simplify test case...

http://jsfiddle.net/PKCG7/

comment:3 Changed 9 years ago by dmethvin

Status: newopen

Confirmed in Opera 11.01 on Windows; I simplified the test case a bit and tried a few permutations:

http://jsfiddle.net/PKCG7/2/

comment:4 Changed 9 years ago by dmethvin

Component: unfiledselector
Milestone: 1.next1.6
Priority: undecidedhigh

comment:5 Changed 9 years ago by dmethvin

#8491 is a duplicate of this ticket.

comment:6 Changed 9 years ago by dmethvin

Keywords: browser-opera added

comment:7 Changed 8 years ago by john

Status: openpending

I think this may have been fixed in Opera 11.1. Can you confirm?

comment:8 Changed 8 years ago by timmywil

Status: pendingopen

comment:9 Changed 8 years ago by john

Milestone: 1.61.next

comment:10 Changed 8 years ago by scottgonzalez

Why is this not higher priority? Having simple selectors fail seems like a blocker.

comment:11 Changed 8 years ago by scottgonzalez

comment:12 Changed 8 years ago by john

Priority: highblocker

comment:13 Changed 8 years ago by john

Keywords: 1.7-discuss added

Nominating ticket for 1.7 discussion.

comment:14 Changed 8 years ago by Rick Waldron

Description: modified (diff)

+1, Seems like a bug, should be fixed

comment:15 Changed 8 years ago by jaubourg

+1, weird

comment:16 Changed 8 years ago by timmywil

+1,

comment:17 Changed 8 years ago by gnarf

Description: modified (diff)

This seems to be an issue in Opera itself... It isn't throwing an exception for Unknown psuedo class when the non-standard :selected is on the right side of the comma...

http://jsfiddle.net/Yxd5P/2/

comment:18 Changed 8 years ago by dmethvin

-1, As discussed in the Monday meeting, this is an Opera bug so I think we should close it wontfix and let the Operatics do their thing.

comment:19 Changed 8 years ago by john

Description: modified (diff)

+0, I fear what's actually happening here. Opera's querySelectorAll is really bad.

comment:20 in reply to:  18 Changed 8 years ago by scottgonzalez

Description: modified (diff)

Replying to dmethvin:

-1, As discussed in the Monday meeting, this is an Opera bug so I think we should close it wontfix and let the Operatics do their thing.

Isn't one of the main purposes of jQuery to overcome browser bugs?

comment:21 Changed 8 years ago by scottgonzalez

Description: modified (diff)

+1

comment:22 Changed 8 years ago by ajpiano

Description: modified (diff)

+0, If this is an opera bug and only affects pseudoselectors, we might have to suck it up. Seems like it could be high cost, low reward...and there could be a fixed Opera, and we know how Opera users are (they love updating).

comment:23 Changed 8 years ago by miketaylr

This was an Opera bug, but it's been fixed in Presto since reported. The problem was "querySelectorAll does not throw for an unsupported pseudo-class part of selector if there is a valid part first."

So, either wait for your users to upgrade to whatever version the fix gets integrated (12? dunno), or don't use custom non-QSA selectors.

comment:24 Changed 8 years ago by Rick Waldron

Keywords: browser-opera 1.7-discuss removed
Milestone: 1.next1.7
Priority: blockerlow

comment:25 Changed 8 years ago by Rick Waldron

Resolution: wontfix
Status: openclosed

comment:26 Changed 8 years ago by sindresorhus

#10921 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.