Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10921 closed bug (duplicate)

Opera 11 - reordering selectors (comma separated) returns different number of elements!

Reported by: [email protected] Owned by: [email protected]
Priority: low Milestone: None
Component: selector Version: 1.7.1
Keywords: opera, qsa Cc:
Blocked by: Blocking:

Description

Shortly, in Opera 11.52 queries bellow return different results (select on the begging, vs select on the end). Works in Opera 12 alpha. Example page is not currently available online, I can send you static html file if needed.

var third = $('select, input:submit, input:checkbox, input:radio, input:file, button').length;
var forth = $('input:submit, input:checkbox, input:radio, input:file, button, select').length;

Change History (6)

comment:1 Changed 10 years ago by sindresorhus

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by [email protected]

Status: pendingnew

Here is example:

http://jsfiddle.net/SnNw6/

try it in Opera 11.52

comment:3 Changed 10 years ago by sindresorhus

Component: unfiledselector
Priority: undecidedlow
Status: newopen

Thanks. Just remember it's important that the testcase is simplified. Posting your whole source to jsfiddle is not good enough, see my testcase for example on how to do it.

I've created a simplified testcase that shows the issue.

I can reproduce the issue in Opera 11.52 and Firefox 3.6, not in Firefox 8, Chrome 15, Safari 5, IE7-9.

comment:4 Changed 10 years ago by sindresorhus

Keywords: opera qsa added
Resolution: duplicate
Status: openclosed

This appears to be a bug with Opera's querySelectorAll.

comment:5 Changed 10 years ago by sindresorhus

Duplicate of #7614.

comment:6 Changed 10 years ago by sindresorhus

Duplicate of #8468

Note: See TracTickets for help on using tickets.