Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7979 closed enhancement (fixed)

subclass enhancment

Reported by: digitalxero@… Owned by: wycats
Priority: blocker Milestone: 1.5
Component: core Version: 1.5b1
Keywords: Cc:
Blocked by: Blocking:

Description

Currently the only top level method that a jQuery subclass gets is 'subclass'. With a small patch you really get a full jQuery subclass and subclassing the subclass does what you would expect and brings over any top level methods/attributes you defined on your subclass.

Patch/Tests @ http://jsfiddle.net/mjTy6/

Change History (11)

comment:1 Changed 8 years ago by jitter

Component: unfiledcore
Type: bugenhancement

Thanks for taking the time to contribute to the jQuery project by writing an enhancement request.

It would be good (and give this suggestion more visibility) if you would file a pull request for this with the changes you made. If you don't know how to do this check

http://docs.jquery.com/Getting_Involved the "Committing and Pull Requests" section and
http://docs.jquery.com/Tips_for_jQuery_Bug_Patching

for more information

comment:2 Changed 8 years ago by digitalxero@…

comment:3 Changed 8 years ago by jitter

Keywords: needsreview added

comment:4 Changed 8 years ago by jitter

Cc: wycats added

comment:5 Changed 8 years ago by digitalxero@…

I would actually consider this a bug in the current subclass implementation as you are not getting a subclass of jQuery you are getting a subclass of jQuery.fn

comment:6 Changed 8 years ago by danheberden

#8077 is a duplicate of this ticket.

comment:7 Changed 8 years ago by ajpiano

Milestone: 1.next1.5
Owner: set to wycats
Priority: undecidedblocker
Status: newassigned

comment:8 Changed 8 years ago by Digitalxero

Resolution: fixed
Status: assignedclosed

Make sure subclass is a proper subclass not just subclassing the fn methods. Fixes #7979.

Changeset: e00f74c43bf58132be01c6417c6126a5bc085899

comment:9 Changed 8 years ago by jitter

Cc: wycats removed
Keywords: needsreview removed

comment:10 Changed 8 years ago by jitter

#5880 is a duplicate of this ticket.

comment:11 Changed 8 years ago by shadedecho

I am not positive that #5880 is in fact a duplicate of this issue. Perhaps I'm misunderstanding, but please review this comment:

http://bugs.jquery.com/ticket/5880#comment:6

Note: See TracTickets for help on using tickets.