Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8077 closed bug (duplicate)

$.subclass has no root functions

Reported by: danheberden Owned by:
Priority: blocker Milestone: 1.5
Component: core Version: 1.5rc1
Keywords: Cc:
Blocked by: Blocking:

Description

While a subclassed item has it's own copy of $.fn, root functions such as $.each aren't copied.

This explains it best: http://jsfiddle.net/danheberden/RhwE4/

A quick summary:

var $sub = $.subclass();
typeof $.each; // "function"
typeof $sub.each // "undefined"

Change History (7)

comment:1 Changed 9 years ago by danheberden

Component: unfiledcore

comment:2 Changed 9 years ago by danheberden

Summary: $.subclass has not root functions$.subclass has no root functions

comment:3 Changed 9 years ago by jitter

Cc: wycats added
Priority: undecidedhigh

comment:4 Changed 9 years ago by jitter

Also check the related #7979

comment:5 Changed 9 years ago by danheberden

Resolution: duplicate
Status: newclosed

comment:6 Changed 9 years ago by danheberden

Duplicate of #7979.

comment:7 Changed 9 years ago by jitter

Cc: wycats removed
Milestone: 1.next1.5
Priority: highblocker
Note: See TracTickets for help on using tickets.