Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5559 closed bug (invalid)

Autocomplete cache

Reported by: gwo Owned by:
Priority: major Milestone: 1.4
Component: misc Version: 1.3.2
Keywords: autocomplete Cc:
Blocked by: Blocking:

Description

Hi, I have a trouble (with the cache i thing) while using autocomplete plugin : I'm using iit with those options :

var autoCompleteOptions = {

dataType: 'json', cacheLength: 1, minChars: 3, width: 250

}

I have one input textbox and i can choose between what to search with the autocomplete with radiobuttons. It works correctly, but when typing text in one textbox, then changing selected radiobutton and then re-typing the same text in the inbox, the same data are beeing shown (they should be different) : so they are invalid. In addition, if I re-tape the same text later in the last textbox, the right data are shown. I have added a flushCache() when switching radiobuttons but the problem persists.

I wonder if i am doing something wrong or if there is a solution for this problem.

Thanks.

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledmisc
Resolution: invalid
Status: newclosed

If this is the UI autocomplete plugin, file a bug report there that includes a test case.

comment:2 Changed 8 years ago by scottgonzalez

#11678 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.