Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3696 closed bug (duplicate)

Firefox 3.0.4 browser version detection fails on Fedora

Reported by: fwenzel Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc: fwenzel
Blocked by: Blocking:

Description

Over at Mozilla, in bug 465822 (https://bugzilla.mozilla.org/show_bug.cgi?id=465822), a problem occurred with the jQuery browser detection and the following User Agent, as used by Fedora Linux:

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc9 Firefox/3.0.4

$.browser.version returns "3.0.4" here. Whereas with an official Mozilla build and a user agent such as:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

it returns 1.9.0.4 (i.e., the Gecko version).

This needs to be made consistent: I would even expect to always get 3.0.4 when asking for the browser version, but the way you do it is up to you. In any case, these two browser instances should return the same value for $.browser.version, so they can be detected correctly.

Change History (3)

comment:1 Changed 11 years ago by flesler

Cc: fwenzel added
Component: unfilledcore
Owner: flesler deleted

comment:2 Changed 11 years ago by dmethvin

Tickets #3696, #3402, #2661, and #2413 are all related, but for different user-agents.

comment:3 Changed 11 years ago by brandon

Resolution: duplicate
Status: newclosed

duplicate of #2661

Note: See TracTickets for help on using tickets.