Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3402 closed bug (duplicate)

jQuery.browser.version can be incorrect with mutant IE userAgent strings

Reported by: dbergey Owned by: flesler
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: browser version msie Cc:
Blocked by: Blocking:

Description

jquery.browser.version currently looks at the last match of /ie ([\d.]+)/ .. it should look for all matches, then use the highest found version. In some situations IE 7 will present itself as both IE 7.0 and IE 6.0 for compatibility, and sometimes the declarations get out of order, not to mention adware and toolbars messing with the registry (see: http://jamazon.co.uk/web/2008/07/23/an-ie7-bug-that-returns-msie-60-user-agent-string/). The attached patch supplements the existing userAgent checking, but could be improved upon.

Attachments (2)

ieversion.patch (360 bytes) - added by dbergey 11 years ago.
ieversion2.patch (243 bytes) - added by dbergey 11 years ago.
Updated patch (fewer lines, future-proofed)

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by dbergey

Attachment: ieversion.patch added

comment:1 Changed 11 years ago by flesler

Owner: set to flesler
Status: newassigned

There were already more than 1 tickets for this, with no 100% successful patch.

I'll keep this ticket in mind for when we handle this.

comment:2 Changed 11 years ago by dbergey

Updated patch to be IE-version-agnostic, and reduced from 7 to 2 lines.

Changed 11 years ago by dbergey

Attachment: ieversion2.patch added

Updated patch (fewer lines, future-proofed)

comment:3 Changed 11 years ago by dmethvin

Tickets #3696, #3402, #2661, and #2413 are all related, but for different user-agents.

comment:4 Changed 11 years ago by brandon

Resolution: duplicate
Status: assignedclosed

duplicate of #2661

Note: See TracTickets for help on using tickets.