Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3395 closed bug (duplicate)

Webkit: .hide() does not work

Reported by: Ti Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: webkit, safari, chrome, hide Cc:
Blocked by: Blocking:

Description

<body>
<script src="jquery-nightly.pack-r5754.js"></script>
<script>
// does not work (in webkit element is visible)
$('<p>hide me before attach</p>').hide().appendTo('body')

// work, element is hidden
$('<p>hide me after attach</p>').appendTo('body').hide() 
</script>
</body>

Change History (4)

comment:1 Changed 11 years ago by flesler

This was already reported and dicussed on the jquery-dev group.

We'll probably fix this for 1.3.

comment:2 Changed 11 years ago by john

Ariel - Which bug(s) relate to this issue? Is this the tracking bug for it? Which discussion mentioned this?

comment:3 Changed 11 years ago by flesler

#3343, #2233, #1239. #1349 and #2575 are slightly related. The discussion is on jquery-dev, very easy to find.

comment:4 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #1239.

Note: See TracTickets for help on using tickets.