Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3343 closed bug (duplicate)

Webkit: .is(':visible') is false for new nodes

Reported by: genezys Owned by:
Priority: major Milestone: 1.3
Component: selector Version: 1.2.6
Keywords: Cc: genezys, flesler
Blocked by: Blocking:

Description

Every other browsers returns true when testing .is(':visible') on newly created nodes (like $('<div/>')). WebKit returns false.

So methods that works with .filter(':visible') don't work on new nodes like .hide().

Test case:

$('<p>Should not be visible</p>').hide().appendTo(document.body);

The problem is real because the workaround is to append the nodes in the document and hide them after resulting in a huge performance hit for large trees.

Change History (2)

comment:1 Changed 11 years ago by flesler

Cc: genezys flesler added
Component: unfilledselector
need: ReviewPatch
Owner: flesler deleted

comment:2 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #1239.

Note: See TracTickets for help on using tickets.