Bug Tracker

Opened 12 years ago

Closed 11 years ago

#2575 closed bug (duplicate)

Hide does not "hide" non-visible elements

Reported by: ereze Owned by:
Priority: minor Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

if I try to do $("#B").hide() and the containing div "#A" is already hidden the action does not change the #B div to display:hidden. Later when I re-show() div #A, #B is displayed as well. Of course, to workaround this, I had to remember to perform on #B before hiding #A.

<div id="A">

<div id="B"> </div>

</div>

Change History (4)

comment:1 in reply to:  description Changed 12 years ago by pelliott

Replying to ereze:

if I try to do $("#B").hide() and the containing div "#A" is already hidden the action does not change the #B div to display:hidden. Later when I re-show() div #A, #B is displayed as well. Of course, to workaround this, I had to remember to perform on #B before hiding #A.

<div id="A">

<div id="B"> </div>

</div>

I just tried this code on the DOM you provided and everything was hidden and shown as expected. I added the letters "A" and "B" into the 2 divs so I could see exactly what was going on and stuck the alerts in for illustration of the progress. It appears as though it is working as expected and this is a non-issue with jQuery 1.2.3.

$(document).ready(function() {

alert("initial state"); $("#A").hide(); alert("A hidden"); $('#B').hide(); alert("B hidden")); $("#A").show(); alert("A shown and B still hidden");

});

comment:2 Changed 12 years ago by flesler

@ereze

Can you confirm this is solved ?

comment:3 Changed 12 years ago by flesler

This seems to be related to the thing that $(':hidden') doesn't get element whose parents are hidden.

comment:4 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a duplicate of #1349.

Note: See TracTickets for help on using tickets.