Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#3383 closed bug (duplicate)

forcing display:block on table, tr td elements

Reported by: Herode Owned by:
Priority: major Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: display block Cc: cbrun@…
Blocked by: Blocking:

Description (last modified by davidserduke)

Some effects of the library set the "display" CSS property to "block". Ex : show()

I tried to apply show() to a <tr> element with a colspan > 1, which caused wrong displays under Firefox, Opera, GoogleChrome (but not IE7).

Here is a sample HTML code to illustrate the issue :

<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Strict//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd'>
<html xml:lang="fr" xmlns="http://www.w3.org/1999/xhtml" lang="fr">  
  <head>		 		     
    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />		     
    <style type="text/css">
	.line_one { background : lime; }
	.line_two {background : red; }
    </style>
  </head>
  <body>    	  
  
    <table>			                                                           
      <tr class="line_one">				                                                   
        <td>colonne 1</td>                                                           
        <td>colonne 2</td>                                                  
      </tr>	
	  
      <tr class="line_two" style="display: block;">			                     
        <td colspan="2">7777777777777777777</td>                                  
      </tr>			       
    </table>  
  </body>
</html>

With "display:block", the second line only occupies one column, despite the colspan=2 request. The problem is that for IE, table, tr and td are of type "block" but under Firefox &co they are of types table, table-row et table-cell.

#NB I temporarily fixed the issue by replacing

  • display = "block"

by

  • display = ""

in the jQuery.js code

Best regards, C.Brun

Change History (5)

comment:1 Changed 11 years ago by flesler

Component: unfilledfx
Owner: flesler deleted

comment:2 Changed 11 years ago by davidserduke

Description: modified (diff)

comment:4 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a duplicate of #2580.

comment:6 Changed 9 years ago by dmethvin

See also #7110.

comment:7 Changed 9 years ago by snover

Duplicate of #2185.

Note: See TracTickets for help on using tickets.