Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14320 closed bug (duplicate)

Calling 'ev.preventDefault()' on latest Chrome Canary (31.0.1619.0) triggers a warning

Reported by: hello@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: dbr Cc:
Blocked by: Blocking:

Description

When using 'ev.preventDefault()', a warning shows on Chrome Canary, this happens only once:

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

JSfiddle: http://jsfiddle.net/blaipratdesaba/kN4WQ/

Change History (10)

comment:1 Changed 4 years ago by hello@…

Been working with other projects, this happens also to previous versions, haven't tested 2.0.x

Looks like the native js method 'event.returnValue' has been marked as deprecated in newer Chrome versions.

comment:2 Changed 4 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #14282.

comment:3 Changed 4 years ago by anonymous

This happens also in :

Google Chrome : 31.0.1650.48 (OS X Version)

and Mozilla Firefox 25.0 (OS X Version)

comment:4 Changed 4 years ago by anonymous

Can confirm this is still happening in Google Chrome : 31.0.1650.48 (OS X Version)

comment:5 Changed 4 years ago by dmethvin

1) Please don't post on duplicate tickets.

2) Please test with the latest version. http://code.jquery.com/jquery-git.js

comment:6 Changed 4 years ago by anonymous

Why didn't you fix this bug yet? It's clearly happening with the latest version of jQuery on any Chrome browser! That's a shame! Please fix ASAP!

jQuery is not what it used to be anymore, lots of bugs wrongly closed or wrongly marked as duplicate... STFU and fix this bug, now.

comment:7 Changed 4 years ago by dmethvin

The bug is fixed in what will become 1.11/2.1. The duplicate bug ticket #14282 explains this. It also explains that older versions of jQuery will give this warning eternally.

comment:9 Changed 4 years ago by dmethvin

This bug has been fixed in what will become jQuery 1.11/2.1

See the duplicate ticket: http://bugs.jquery.com/ticket/14282

Further comments on this ticket will be deleted.

comment:10 Changed 4 years ago by scottgonzalez

Keywords: dbr added
Note: See TracTickets for help on using tickets.