Bug Tracker

Ticket #14282 (closed bug: fixed)

Opened 16 months ago

Last modified 10 months ago

Don't call getPreventDefault() if there is a defaultPrevented property

Reported by: dmethvin Owned by: dmethvin
Priority: high Milestone: 1.11/2.1
Component: event Version: 1.10.2
Keywords: dbr Cc:
Blocking: Blocked by:

Change History

comment:1 Changed 16 months ago by m_gol

On 2.x we could probably implement defaultPrevented using an ES5 getter? 1.x requires typeof checks, unfortunately.

comment:2 Changed 16 months ago by m_gol

OTH implementation using a getter would be larger so maybe it's better to use in in 2.x.

comment:3 Changed 16 months ago by dmethvin

ES5 features tend to be slow, so the typeof check may be the best for both branches.

comment:4 Changed 16 months ago by m_gol

typeof on both or typeof in 1.x & in in 2.x? Would be shorter.

comment:5 Changed 16 months ago by m_gol

I agree on the ES5 case, though, especially that Android 2.3 devices aren't demons of speed.

comment:6 Changed 16 months ago by dmethvin

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to event
  • Milestone changed from None to 1.11/2.1

Note to all who feel compelled to comment here: We are aware of the message, which is just a warning and has no effect on functionality. Do not post "me toos" or "when will this be fixed" here. It's scheduled to be fixed in the next release as shown in the status.

Note that even after the new vesion is released, older jQuery versions will continue to generate this message forever -- or until Chrome decides to remove the message.

comment:7 Changed 16 months ago by dmethvin

#14320 is a duplicate of this ticket.

comment:8 Changed 15 months ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:9 Changed 15 months ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #14282. Don't fondle getPreventDefault if preventDefault exists. Close gh-1365.

Changeset: 4671ef15c2d62962048fd4863911146fcc085f26

comment:10 Changed 13 months ago by dexter

I tested it with the 1.10.2 (as scheduled) release and i still get this message.

comment:12 Changed 13 months ago by m_gol

@dexter: please pay more attention next time, the bug was reported to exist exactly in the 1.10.2 you mentioned, it'll be fixed in 1.11. Beta is available.

Last edited 13 months ago by m_gol (previous) (diff)

comment:13 Changed 13 months ago by m_gol

#14546 is a duplicate of this ticket.

comment:16 Changed 13 months ago by anonymous

Problem went away for me using 1.11-beta2 linked above.

comment:19 Changed 13 months ago by scott.gonzalez

  • Keywords dbr added

comment:21 Changed 13 months ago by timmywil

#14601 is a duplicate of this ticket.

comment:22 Changed 13 months ago by timmywil

#14599 is a duplicate of this ticket.

comment:23 Changed 11 months ago by scott.gonzalez

#14679 is a duplicate of this ticket.

comment:24 Changed 11 months ago by timmywil

#14713 is a duplicate of this ticket.

comment:25 Changed 10 months ago by anonymous

#14713 is a duplicate of this ticket.  hussvamp Svartmögel mögel i hus

comment:26 Changed 10 months ago by anonymous

Note: See TracTickets for help on using tickets.