Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13612 closed bug (duplicate)

$("select").val() throws a warning

Reported by: dethrall@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

the .val() Method gives me a warning in the console, if i try to get the value of a select element. no matter through which selector. the problem only appears in firefox 19.0.2. I am not sure but the problem wasn't there on 19.0. IE9 and Chrome are not affected.

Warning: "Das angegebene Attribut auf Attributen sollte nicht mehr verwendet werden. Es liefert immer true."

return !val || val.specified ? elem.value : elem.text;

jquery-1.9.1.js (Zeile 2270)

Browser: Firefox 19.0.2 on Win 7 Fiddle: http://jsfiddle.net/4EuGZ/3/

Change History (2)

comment:1 Changed 7 years ago by iklotzko

This looks like a duplicate of ticket:11397 (Please see comment:12:ticket:11397) which is a duplicate of ticket:12072.

Last edited 7 years ago by iklotzko (previous) (diff)

comment:2 Changed 7 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #12072.
This will be fixed in 1.10.

Note: See TracTickets for help on using tickets.