Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#13261 closed bug (fixed)

Ajax response with status code 204 must not be parsed

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

In case the response to an ajax call returns with an HTTP status 204/No Content, jQuery must not try to apply any converters on the response but simply pass it on.

See this example: http://jsfiddle.net/mbhp2/

Change History (5)

comment:2 Changed 10 years ago by byroot

Resolution: fixed
Status: newclosed

Don't try and convert data for 204 No Content responses. Fixes #13292. Fixes #13261.

Changeset: bfc61b879e9e94ef7c6b31919b7f287ffdf180a8

comment:2 Changed 10 years ago by byroot

Resolution: fixed
Status: newclosed

Don't try and convert data for 204 No Content responses. Fixes #13292. Fixes #13261.

Changeset: eb47553eeac58861bcefac063c0e03e161b4d52c

comment:3 Changed 10 years ago by dmethvin

#13319 is a duplicate of this ticket.

comment:4 Changed 10 years ago by ojak

As of 1.9.1, even though response 204 triggers success, it still triggers the fail() block on cross domain requests. This ticket should be reopened.

Last edited 10 years ago by ojak (previous) (diff)
Note: See TracTickets for help on using tickets.