Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13319 closed bug (duplicate)

Ajax request on resource that returns a 204 triggers a fail.

Reported by: hello@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Executing an Ajax request on a ressource that returns a "204 No Content" triggers the fail-handler. This happens because jQuery tries and fails to parse the empty body.

Example (with minimalistic Node.js server code): http://jsfiddle.net/BbEbJ/

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13261.

Note: See TracTickets for help on using tickets.