Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12861 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'8c397a90e379a36baa92ac18',
 'recaptcha_challenge_field': u'03AHJ_VutvIj3Gj7IWx2BNZMtFFjhWywm-fcBBWcsceb2Z1E3STifkm696w57BvwmkOo6_5sp6a5jEcXaVxR-x7YR7gf8G7heQ7d0l1Js48jaSsTz7kO2c-aNruymL889LboyTsrX3iXyng9NIPQGlix3QIpigQOvWuVoaiJ8rvygfOOp2pULJuqMJCBEEV_HFL-p0ARBy-ORJ',
 'recaptcha_response_field': u'Delgati obtained."'}

User agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.3; .NET4.0C; .NET4.0E)

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #12401.

Note: See TracTickets for help on using tickets.