Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12401 closed bug (invalid)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version:
Keywords: Cc: gnarf
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'22f52b2760ea410970016e19',
 'recaptcha_challenge_field': u'03AHJ_Vusan9OFKEVe3hw24_fEpwH8F_jM62v6KKFq6FoPNlrE_9mdC_ktfDOyac9mGXg8RWaz_1s3acDHKmRj1EikVZvREa5qqp97t0rIViB9nLXNUNFawTGoDCU5LqplTxNmWezMT_YMNFMlgaXCeYJhwD0w8mGSIuc3a4o0BQ4NjGGw3Gwe5V4',
 'recaptcha_response_field': u'eatedaw unlimited'}

User agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.81 Safari/537.1

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (4)

comment:1 Changed 7 years ago by mikesherov

Cc: gnarf added

If we update trac, this is fixed. Gnarf, any thoughts? http://trac.edgewall.org/ticket/9697 can you add this to the infra tracker?

comment:2 Changed 7 years ago by mikesherov

Resolution: invalid
Status: newclosed

Thanks for reporting this bug! It will be fixed shortly, but I'm closing it on this bug tracker, as it's been ported to another tracker we use for issues that aren't related to core jQuery code.

comment:3 Changed 7 years ago by mikesherov

#11186 is a duplicate of this ticket.

comment:4 Changed 7 years ago by timmywil

#12861 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.