Bug Tracker

Opened 7 years ago

Closed 7 years ago

#11186 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: maspwr Owned by: danheberden
Priority: low Milestone: None
Component: web Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'dc59cffd8e995a45da939782',
 'recaptcha_challenge_field': u'03AHJ_Vus-fJ7JklWO-s03etYJFRHO1fls8bGzH_yN-7BQQmONxnj7D95FCmo2VudHD-rscc_VfRyTjkK5HDmPUrU1M0W_Xlrb93jc2XP28QL7ydDQViXdWI8uBNNcOLk3DHe8JwtBLw-Fqh2GWDMby6wGoNuUdZzktg',
 'recaptcha_response_field': u'142. catichK'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.52.7 (KHTML, like Gecko) Version/5.1.2 Safari/534.52.7

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (3)

comment:1 Changed 7 years ago by Rick Waldron

Component: unfiledweb
Owner: set to danheberden
Status: newassigned

comment:2 Changed 7 years ago by mikesherov

Priority: undecidedlow

http://trac.edgewall.org/ticket/9697 how do we go about updating trac plugins?

comment:3 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: assignedclosed

Duplicate of #12401.

Note: See TracTickets for help on using tickets.