Skip to main content

Bug Tracker

Side navigation

#12862 closed bug (cantfix)

Opened November 07, 2012 06:56PM UTC

Closed September 13, 2013 08:07PM UTC

Event propagation halted when synchrounous ajax call happens within an event

Reported by: drew.waddell Owned by: drew.waddell
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

This is an odd issue. I have done lots of debugging to try to figure out what is actually occurring but I have not figured it out.

This is an issue in Firefox, Internet Explorer handles the events perfectly. I have not tried any other browser.

I am not sure if this is an issue somewhere in the synchronous code, or if there is a Firefox setting I am unaware of such as a event timeout, or a Firefox bug.


Screen Capture video:

Steps to reproduce:

1. Bring up Firebug

2. Click in the first textarea, an async request is fired, no issue ever happens

3. Click in the second textarea, a sync request is fired, notice if the sync ajax request takes ~70ish ms to respond the next click out of the textarea will not trigger, else there is no issue

I added the link to the video because I understand the issue is rather odd and it may be confusion follow the steps to reproduce, I am hoping that with both it will be easy to reproduce.

Thanks for looking,


Attachments (0)
Change History (8)

Changed November 07, 2012 09:13PM UTC by dmethvin comment:1

owner: → drew.waddell
status: newpending

Don't count out the possibility that Firebug is affecting the browser. Try disabling all plugins and see if the behavior changes. From the description it seems like this may be a Firefox issue that they would have to fix. Can you create a test case with plain XHR and addEventListener to rule out jQuery code?

Changed November 08, 2012 03:09PM UTC by drew.waddell comment:2

status: pendingnew


I've removed the jQuery part for the second textarea, I seem to still be getting the issue. I didn't remove all the jQuery though, should I do that or do you think that is overkill?



Changed November 08, 2012 03:21PM UTC by drew.waddell comment:3

Also, I tried with plugins disabled, no Firebug running. It was still an issue.

Changed November 21, 2012 06:37PM UTC by dmethvin comment:4

resolution: → notabug
status: newclosed

Sorry but this is much too complex at the moment to be called a bug with jQuery core. You'll need to reduce this to something simpler. It might also be useful to try making a jQuery-free example to see if it really is a Firefox bug.

Changed September 13, 2013 07:41PM UTC by cmcnulty comment:5

For the record, I hit this bug, and can confirm that it is a Firefox bug:

The bug's been reported at least once that I can find - current status is unconfirmed:

Changed September 13, 2013 07:46PM UTC by dmethvin comment:6

_comment0: I filed a bug report for this at Mozilla as well: \[]1379103197065767

I filed a bug report for this at Mozilla as well:

Changed September 13, 2013 08:05PM UTC by dmethvin comment:7

resolution: notabug
status: closedreopened

Changed September 13, 2013 08:07PM UTC by dmethvin comment:8

resolution: → cantfix
status: reopenedclosed

I can't think of a workaround, so I'll change the resolution accordingly. Thanks for the bugzilla reference cmcnulty!