Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12749 closed bug (fixed)

position() does not handle position:fixed elements correctly

Reported by: fracmak2 Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking: #11671

Description

Fixed element's are relative to the viewport, position() treats position fixed elements relative to their dom parent's offset parent.

http://jsfiddle.net/fracmak/v59CB/4/

Change History (4)

comment:1 Changed 7 years ago by fracmak2

comment:2 Changed 7 years ago by jaubourg

Blocking: 11671 added

comment:3 Changed 7 years ago by Merrifield, Jay

Resolution: fixed
Status: newclosed

Fixes #12749, correctly detect position() for position:fixed elements, closes gh-991

Changeset: 425272aea1fb30b734bac25b8f74dbe85a3ce215

comment:4 Changed 7 years ago by mikesherov

#11671 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.