Bug Tracker

Opened 5 years ago

Closed 5 years ago

#11671 closed bug (duplicate)

.offset() setter handles fixed positioned elements incorrectly in Chrome

Reported by: scottgonzalez Owned by: fracmak2
Priority: low Milestone: 1.next
Component: offset Version: 1.7.2
Keywords: Cc:
Blocked by: #12749 Blocking:

Description

When the window is scrolled, .offset() will incorrectly include the scroll distance when setting the position of fixed positioned elements in Chrome.

http://jsfiddle.net/v59CB/

Change History (8)

comment:1 Changed 5 years ago by scottgonzalez

#11699 is a duplicate of this ticket.

comment:2 Changed 5 years ago by sindresorhus

Component: unfiledoffset
Priority: undecidedlow
Status: newopen

comment:3 Changed 5 years ago by fracmak2

This also affects IE8/9

comment:4 Changed 5 years ago by jaubourg

Milestone: None1.next
Owner: set to fracmak2
Status: openassigned

comment:5 Changed 5 years ago by jaubourg

Blocked by: 12749 added

comment:6 Changed 5 years ago by fracmak2

This needs to be rechecked when #12749 lands. Should be fixed by it.

comment:7 Changed 5 years ago by fracmak2

Verified that this is fixed in all browsers now in jQuery.edge

http://jsfiddle.net/fracmak/v59CB/5/

This ticket can now be closed

comment:8 Changed 5 years ago by mikesherov

Resolution: duplicate
Status: assignedclosed

Duplicate of #12749.
Like a boss, Jay.

Note: See TracTickets for help on using tickets.