Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11699 closed bug (duplicate)

Jquery offset() strange positioning of fixed positioned elements

Reported by: samuel.hapak@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Jquery offset() does strange things, when called on fixed positioned element.

First call of myFixedElement.offset(position) positions element relative to window, all next calls will position it relative to document.

You can try demo. Just scroll to the bottom and click on "Hell yes". Notice the "Hell no" disappearing. Click again. "Hell no" will show again.

Change History (3)

comment:1 Changed 7 years ago by samuel.hapak@…

comment:2 Changed 7 years ago by scottgonzalez

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by scottgonzalez

Duplicate of #11671.

Note: See TracTickets for help on using tickets.