Bug Tracker

Opened 7 years ago

Closed 6 years ago

#12447 closed bug (fixed)

Slide animation dont work correctly in 1.8.0

Reported by: lapynow.d@… Owned by: gibson042
Priority: high Milestone: 1.next
Component: effects Version: 1.8.0
Keywords: Cc: gibson042, gnarf
Blocked by: Blocking:

Description

Heya, case below contains a small code that implement contents sliding animation, pressing menu items with classes 'mmenu_bth'. In jQuery 1.8.0. i have freezes andsometimes hangs in browser, when i do 4-5 clicks on different menu items consequentially.

Test case: http://jsfiddle.net/KKmTD/5/

Important notes:

  1. Opening console(native or Firebug) fix this behavior (no freezes, no hangs).
  2. Code work well with older jQuery versions.
  3. Works fine with other browsers: Chrome, Safari, IE 9.
  4. Regress to 1.7.2. version cause an other error in positioning calculation - in Chrome position caclucales incorrectly.

Change History (9)

comment:1 Changed 7 years ago by lapynow.d

Important note: in jsFiddle code works fine with any jQuery ver. But problem occur when I test code directly in Firefox 15-16.

comment:2 Changed 7 years ago by lapynow.d@…

This question is investigated in bugzilla and more information you can get here: https://bugzilla.mozilla.org/show_bug.cgi?id=787782

comment:3 Changed 7 years ago by mikesherov

Cc: gibson042 gnarf added

gnarf, gibson042... check out that infinite loop...

comment:4 Changed 7 years ago by dmethvin

Yeah, it does seem like those need to be fuzzy equals.

comment:5 Changed 7 years ago by gibson042

Component: unfiledeffects
Milestone: None1.next
Owner: set to gibson042
Priority: undecidedhigh
Status: newassigned

comment:6 Changed 7 years ago by dmethvin

#12495 is a duplicate of this ticket.

comment:7 Changed 7 years ago by dmethvin

#12507 is a duplicate of this ticket.

comment:8 Changed 7 years ago by petersphilo

Hello,

in all of the v1.7.x versions of jQuery core that i used, the .animate() method starts the animation from its current position (like margin), particularly if multiple animations are applied to the same object.
Now, in v1.8.0 and v1.8.1, the .animate() method starts from the same place, regardless of the current position of the object.
Here are 2 examples; in this website, i use .animate() to slide each 'page' horizontally by changing the 'left-margin' property
here is v1.7.1 at work (click on the page titles to navigate):
http://ab-expert.fr
and now v1.8.1 (click on the page titles to navigate):
http://ab-expert.fr/index-prob.html

Note!: The fiddle below shows that even v1.7.2 differs from v1.7.1 or even before (like v1.6.x) since it does not animate the second movement:
http://jsfiddle.net/petersphilo/mGkdr/1/

I Hope this helps!

comment:9 Changed 6 years ago by gibson042

Resolution: fixed
Status: assignedclosed

Fix #12447: Ensure starting-point calc takes finite time. Close gh-922.

Changeset: e755c194161e1dc6793cbb690ba8334dad560c8f

Note: See TracTickets for help on using tickets.