Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12507 closed bug (duplicate)

.animate() does not start from existing position in v1.8.1 as it did in v1.7.x

Reported by: petersphilo Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

in all of the v1.7.x versions of jQuery core that i used, the .animate() method starts the animation from its current position (like margin), particularly if multiple animations are applied to the same object. Now, in v1.8.0 and v1.8.1, the .animate() method starts from the same place, regardless of the current position of the object. Here are 2 examples; in this website, i use .animate() to slide each 'page' horizontally here is v1.7.1 at work (click on the page titles to navigate): http://ab-expert.fr and now v1.8.1 (click on the page titles to navigate): http://ab-expert.fr/index-prob.html

i hope this helps

Change History (3)

comment:1 Changed 7 years ago by petersphilo

So Sorry, here is the ticket with at least a little bit of formatting for readability...

Hello,

in all of the v1.7.x versions of jQuery core that i used, the .animate() method starts the animation from its current position (like margin), particularly if multiple animations are applied to the same object.
Now, in v1.8.0 and v1.8.1, the .animate() method starts from the same place, regardless of the current position of the object.
Here are 2 examples; in this website, i use .animate() to slide each 'page' horizontally by changing the 'left-margin' property
here is v1.7.1 at work (click on the page titles to navigate):
http://ab-expert.fr
and now v1.8.1 (click on the page titles to navigate):
http://ab-expert.fr/index-prob.html

i hope this helps

comment:2 Changed 7 years ago by petersphilo

i have added another example to illustrate the difference between v1.8.x and v1.7.x
(largely used the code from ticket #12504 (thank you)

http://jsfiddle.net/petersphilo/mGkdr/

Hope This helps!

Last edited 7 years ago by petersphilo (previous) (diff)

comment:3 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12447.

Note: See TracTickets for help on using tickets.