Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11765 closed enhancement (duplicate)

Allow delegated non-native events on disabled elements

Reported by: jmarston Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Currently jQuery does not call delegated event handlers for disable elements. This is to keep consistency between browsers because IE is the only browser that raises events on disabled elements (see #6911 and #8165).

It would be useful, however, if we could raise non-native events with trigger() on disabled elements and still have delegated handlers be run. Since jQuery would be handling the triggering, bubbling, and dispatching there wouldn't be any browser inconsistencies.

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by dmethvin

Duplicate of #11764.

Note: See TracTickets for help on using tickets.