Bug Tracker

Opened 13 years ago

Closed 9 years ago

Last modified 9 years ago

#1172 closed enhancement (wontfix)

Ajax Partial results for better busy status.

Reported by: jakecigar Owned by:
Priority: low Milestone:
Component: ajax Version: 1.1.2
Keywords: ajaxrewrite Cc:
Blocked by: Blocking:

Description

diff -u ajax-orig.js ajax.js
--- ajax-orig.js        2007-04-12 12:27:36.000000000 -0700
+++ ajax.js      2007-05-07 09:18:19.000000000 -0700
@@ -708,6 +708,10 @@
                                if(s.async )
                                        xml = null;
                        }
+                       else if (xml && xml.readyState == 3){
+                               if (s.partial)
+                                       s.partial( xml, 'partial' );
+                       }
                };
 
                // don't attach the handler to the request, just poll it instead


I have a demo, it just shows the count of characters.

But kills opera with the over 4meg ajax load, works fine in FF 2 & Safari.

http://jpassoc.com/Library.html

$(function(){

	$.ajax(
		{type: "GET"

		,url: '/cat.cgi?Library.xml'

		,complete:function(r){
			var t = r.responseText

			$('#status').text('loaded')

			var v = t.substr(0,500) + '…'
			$('#msg').text(v)

		 }
		,
partial:function(r){
			var t = r.responseText

			$('#status').html(t.length)

		 }
		})

});

Change History (8)

comment:1 Changed 9 years ago by dmethvin

Milestone: 1.1.31.5

comment:2 Changed 9 years ago by snover

Milestone: 1.4.41.5

Retarget all enhancements/features to next major version.

comment:3 Changed 9 years ago by snover

Keywords: needsreview added
Priority: majorlow

Bikeshed/feature creep. Marking for review.

comment:4 Changed 9 years ago by snover

#5585 is a duplicate of this ticket.

comment:5 Changed 9 years ago by dmethvin

Keywords: needsreview removed
Status: newopen

Worth a look; we can accept/reject with the upcoming ajax rewrite.

comment:6 Changed 9 years ago by Rick Waldron

Keywords: ajaxrewrite added

comment:7 Changed 9 years ago by dmethvin

Resolution: wontfix
Status: openclosed

See the solution proposed in #8237, based on the ajax prefilter feature added in 1.5.

comment:8 Changed 9 years ago by anonymous

Proposed solution is actually #8327

Note: See TracTickets for help on using tickets.