Bug Tracker

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11397 closed bug (duplicate)

$('#some_select').val() results in "use of attributes specified attribute is deprecated" warning on Firefox 7+

Reported by: glob Owned by: glob
Priority: low Milestone: 1.next
Component: attributes Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

$('#some_select').val() results in "use of attributes' specified attribute is deprecated" warning on firefox.

jquery is referencing the "specified" property on an Attr object, this is depreciated with Firefox 7, and always returns true. see https://developer.mozilla.org/En/DOM/Attr

the problem appears to be at line 2630 of 1.7.1:

return attributeNode && attributeNode.specified ?

Change History (12)

comment:1 Changed 5 years ago by sindresorhus

  • Owner set to glob
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 5 years ago by glob

  • Status changed from pending to new

comment:3 Changed 5 years ago by dmethvin

  • Component changed from unfiled to attributes
  • Priority changed from undecided to low
  • Status changed from new to open

comment:4 Changed 4 years ago by anonymous

Last changed 3 month ago..nothing happening here?

comment:5 Changed 4 years ago by dmethvin

Sorry, anonymous, did we miss your pull request?

comment:6 Changed 4 years ago by mail.someone@…

Bump it up ..still present in 1.8b2

Though it seems not to be in the same place

 valHooks: {
	option: {
		get: function( elem ) {
			// attributes.value is undefined in Blackberry 4.7 but
			// uses .value. See #6932
			var val = elem.attributes.value;
			return !val || val.specified ? elem.value : elem.text;
		}
	}, 

comment:7 Changed 4 years ago by Dave Methvin

  • Resolution set to fixed
  • Status changed from open to closed

Fix #11397. Shush Firefox warning by re-breaking #6932 for BB 4.7.

At this point BlackBerry 4.7 (and related ancient browsers) should be scarce (released circa 2008) so #6932 will be closed wontfix for this edge case.

Changeset: e866893fd29b0328ebc282cf0ba716e6f87384c3

comment:8 Changed 4 years ago by Dave Methvin

Revert "Fix #11397. Shush Firefox warning by re-breaking #6932 for BB 4.7."

This reverts commit e866893fd29b0328ebc282cf0ba716e6f87384c3.

Failures in IE6 when this is removed, unfortunately.

Changeset: c29660c5936b76787c4a864d8188b325bc81a81f

comment:9 Changed 4 years ago by dmethvin

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 4 years ago by dmethvin

  • Milestone changed from None to 1.next
  • Status changed from reopened to open

comment:11 Changed 4 years ago by dmethvin

  • Resolution set to duplicate
  • Status changed from open to closed

Moving these all under #12072. At this time we are not in need of any additional "me too", "hey I see this on my console", or "when are you going to fix this" messages. We are aware of the issue.

comment:12 Changed 4 years ago by dmethvin

Duplicate of #12072.

Note: See TracTickets for help on using tickets.