Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#10712 closed bug (fixed)

Triggering blur with live bind broken

Reported by: gabelerner@… Owned by: dmethvin
Priority: high Milestone: 1.7.1
Component: event Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/QrNXX/

clicking into box and blurring via browser alerts.

onload it doesn't alert (it should, and does if you switch version to 1.6.4)

Change History (4)

comment:1 Changed 5 years ago by dmethvin

  • Component changed from unfiled to event
  • Milestone changed from None to 1.7.1
  • Owner set to dmethvin
  • Priority changed from undecided to high
  • Status changed from new to assigned

Ugh. This is because blur bubbles as focusout. The element isn't really focused (you're just trying to run the handlers) so the browser doesn't fire a blur or focusout event. It's a legit use case though.

comment:2 Changed 5 years ago by gabelerner@…

Thanks for looking at it!

Focusing on it prior to running blur does indeed work. http://jsfiddle.net/GLjFg/

Also, trying to go through trigger('blur') does not work, whereas a custom event does. http://jsfiddle.net/yPY2G/

comment:3 Changed 5 years ago by Dave Methvin

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix #10712. Deal with focus/blur morphing to focusin/focusout.

Changeset: 39f9b846e722600aece0a5428e38e9b12217395e

comment:4 Changed 5 years ago by dmethvin

#10803 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.