Bug Tracker

Ticket #9823 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

IE 8 crashes when using background-image on BODY in css

Reported by: cdgrit@… Owned by: timmywil
Priority: blocker Milestone: 1.6.3
Component: support Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

IE 8 crashes when using background-image on the BODY in my css file. Using version 1.6.2. When using version 1.6.1 the browser doesn't crash.

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to cdgrit@…
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to support

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on  http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 3 years ago by jelle@…

This is a regression; lines 1281-1282 in 1.6.1:

Set background to avoid IE crashes when removing (#9028) background: "none"

These lines were removed from 1.6.2, causing this crash. Reintroducing them after line 1296 in 1.6.2 solves the crash!

comment:4 Changed 3 years ago by jelle@…

Lines 1281-1282 properly formatted (my bad):

  // Set background to avoid IE crashes when removing (#9028)
  background: "none"

comment:5 Changed 3 years ago by john

  • Priority changed from low to blocker
  • Status changed from closed to reopened
  • Resolution invalid deleted
  • Milestone changed from None to 1.7

Good catch, we'll tackle this.

comment:6 Changed 3 years ago by john

  • Milestone changed from 1.7 to 1.6.3

comment:7 Changed 3 years ago by timmywil

  • Status changed from reopened to pending

I have not been able to reproduce this and we have a test for this in the test suite. Is there a test case that causes the crash? Setting background: 'none' should have no effect on any existing body elements since we create a div if a body exists.

comment:8 Changed 3 years ago by timmywil

  • Owner changed from cdgrit@… to timmywil
  • Status changed from pending to assigned

From JorisDebonnet:

Go to  http://fiddle.jshell.net/ZKPZq/6/ with IE8. Right click in the result screen, and make it refresh. Boom, crash.

comment:9 Changed 3 years ago by timmywil

  • Status changed from assigned to closed
  • Resolution set to fixed

Add back the background: none setting to avoid any possible crashes in IE from the support testElement. Fixes #9823.

Changeset: 5c4a9cc001fcd803efa65ff95571c72cbdafbe69

comment:10 Changed 3 years ago by timmywil

#10025 is a duplicate of this ticket.

comment:11 Changed 3 years ago by timmywil

#10128 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.