Bug Tracker

Modify

Ticket #9072 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

jQuery 1.6 Crashes IE 6

Reported by: john Owned by:
Priority: blocker Milestone: 1.6.1
Component: manipulation Version: 1.6
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by john) (diff)

Simple reproduce case:

  <html>
  <head>
  <script src="http://code.jquery.com/jquery-1.6.min.js"></script>
  </head>
  <body>
  <script>
  $('body').append(
    '<span></span>',
    '<span></span>',
    '<span></span>'
  )
  </script>
  </body>
  </html>

The bug is in this block:  https://github.com/jquery/jquery/blob/1.6/src/manipulation.js#L652

Note the inner loop is clobbering the outer loop's "i" variable.

From here:  http://news.ycombinator.com/item?id=2510844

Change History

comment:1 Changed 3 years ago by john

  • Description modified (diff)

comment:2 Changed 3 years ago by john

  • Priority changed from undecided to blocker
  • Component changed from unfiled to manipulation
  • Milestone changed from 1.next to 1.6.1

comment:3 Changed 3 years ago by John Resig

  • Status changed from new to closed
  • Resolution set to fixed

Fix problem with appending multiple string arguments in IE 6. Fixes #9072.

Changeset: bfad45fe4510db78a38170752ccc9c9efe5f38b6

comment:4 Changed 3 years ago by timmywil

#9107 is a duplicate of this ticket.

comment:5 Changed 3 years ago by timmywil

#9110 is a duplicate of this ticket.

comment:6 Changed 3 years ago by anonymous

A heads up: I see this was fixed in jQuery 1.6.1 but  http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.js, which I thought was the latest jQuery, has the bug in it. I wasted hours debugging today because of this.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.