Bug Tracker

Modify

Ticket #9107 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

.append() with multiple elements on IE7+ causes endless loop in jquery

Reported by: Indoom Owned by:
Priority: high Milestone: 1.next
Component: manipulation Version: 1.6
Keywords: Cc:
Blocking: Blocked by:

Description

When appending more then 2 elements on quirks mode, it makes IE7+ go in endless loop. Or if doctype is set, then just IE7. Haven't tested on IE6. If append() has two elements, then it appends only the first, but no endless loop then

var div1 = $("<div>"),
    div2 = $("<div>"),
    div3 = $("<div>");		
$("body").append( div1, div2, div3 );

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to manipulation

comment:2 Changed 3 years ago by timmywil

Duplicate of #9072.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.